Inane Coding Go on, slap that wayward code

28Mar/200

v3.0 Release of Matomo eCommerce Analytics PRO for Opencart

 

Version 3.0 of my Matomo eCommerce Analytics PRO for Opencart extension has just been released. I've tested compatibility with the latest OpenCart 3.0.3.2 and Matomo 3.13.3

This is now available to purchase.

2020/03/25
Support for Opencart v3.x , including new Twig templating and easy OCMOD install.
Support for latest Matomo v3.x , updates MatomoTracker.php and proxy scripts.
Added Dashboard widget for Matomo Analytics to the Opencart Admin Dashboard.
Added eCommerce 'Categories' tracking for Product & Category views, & Cart updates.
Added automatic resolution of MatomoTracker.php location for easier setup.
Added compatibility with mods which remove 'Powered by Opencart' message.
Set eCommerce tracking to be Enabled by default
Changed eCommerce Product View reported price; takes account of special pricing.
Changed Cart total reported price; now Incl. Taxes, for consistency in Matomo.
Changed Site Search Tracking to be fully javascript for consistency.
Changed Site Search Tracking, reports full category "A > B > C" instead of end "C".
Added proxy.php validation check, to check file is writeable upon saving settings.
Added check to only include setEcommerceView() if on Product or a Category page.
Fixed uncaught exception if Opencart 'SKU' product field used but product 'SKU' empty.

Note: This release and future main releases will be for OpenCart 3.x and will not work with OC2.x - however v2.0 of this mod is still available which supports OC 2.0.

As with the previous releases, the mod is now up on the opencart.com extension store.

As always please let me know your feedback!

Thanks!

Kevin

Share
3May/152

v2.0 Release of Piwik OpenCart Ecommerce VQmod

Version 2.0 of my Piwik OpenCart Ecommerce VQmod has just been released. I've tested compatibility with the latest OpenCart 2.0.2.0

Credit goes to Jozef Popiel ( https://github.com/Oseexperts) as he wrote most of the code changes for this release.

Enjoy!

This is now available to download. Remember to check out the mods github page.

2015/05/03
Provide compatibility for OC2.x , no longer supports OC1.x (jump to v2.0)
Update piwik proxy & piwiktracker file to latest

Note: This release and future main releases will be for OpenCart 2.x and will not work with OC1.x - however v1.1 of this mod is still available which supports OC 1.5.6.4 - future releases on the v1.x numbering will be done for any critical changes needed to maintain OC1.x compatibility.

As with the previous releases, the mod is now up on the opencart.com extension store.

As always please let me know your feedback!

If you do use this mod please consider donating. Thanks!

Kevin

Share